Delta Dental Outage

Incident Report for ZKeep

Resolved

Delta has returned their sites to service. We will continue to monitor their status and post here if there are changes.
Posted Sep 18, 2026 - 15:09 UTC

Investigating

We are seeing an outage across numerous Delta Dental sites on the payor side. We will continue to monitor the status of the Delta sites and will post updates here when they return to service. They are reporting "Unexpected system error" post login.

Zkeep remains healthy.
Posted Sep 18, 2026 - 14:27 UTC
This incident affected: Specific Tiles.